logs archiveBotHelp.net / Freenode / #2600hz / 2015 / September / 17 / 1
alpha-z
this sucks.. nothing i do seems to work
CanDo
alpha-z, search for t38 in https://github.com/2600hz/kazoo/blob/master/applications/ecallmgr/src/ecallmgr.hrl
Try some of those in your offnet config.
alpha-z, Looks like values for them would be true/false.
alpha-z
values for those ones in the hrl you sent me?
like Enable-T38-Fax?
err rather fax_enable_t38 = false in the offnet?
but arent those channel variables?
CanDo
alpha-z, usually the setting name in the config is lower case. I would try something like "fax_enable_t38_request": false
alpha-z
under media in the offnet or under gateway?
CanDo
I would guess under gateway, but might also try under media.
it's a little tricky following where some of the setting originate from. :P
lazedo
alpha-z: media : { fax_option : false }
alpha-z
ya i have fax_option : false on the device too...
but it always seems to come back with t38
maybe reload_resources isnt enough
lol in my carrier gateway i now have "t38_setting": "false",
"fax_enable_t38": "false",
"fax_enable_t38_request": "false",
"t38_passthru": "false",
and in media i have "fax_option": "false",
and i reloaded resource and it still doing t38... wth.. .
and i have fax_option: false in the specific device doc too
lazedo
alpha-z: your version ?
alpha-z
lazedo..
my problem
just snowballed into a whole completely different problem...
sad...
so apparently now my provider supports t38...
after calling them
it was apparently them that kept sending the reinvite for t38...
so i went around and re-enabled t38 everywhere... in kazoo and in ictfax.
the fax is not going through but i know why but i dont know how to fix..
the leg between ictfax and kazoo is supposed to be internal. but the kazoo at some point sends sip packets with contact: external ip instead of internal
so then the ictfax (freeswitch) sends any future packets to the external ip which just doesnt happen
i assume that has smoething do with sip profiles and ext-ip or something
anyone around?
CanDo
alpha-z, kind of
alpha-z
hey cando, the reinvites for t38 seem to get lost in space between kazoo and ictfax..
CanDo
alpha-z, you see them proceeding out FS but no evidence on ictfax?
Might it be ictfax ignores them since you turned off t38?
alpha-z
on ictfax, i see some send and receives before t38, then i see ictfax send a t38 reinvite, to kazoo
i turned all t38 back on
then it sends another invite because it doesnt hear back from kazoo
CanDo
alpha-z, is your FS and kamailio on the same server?
alpha-z
for this particular kazoo yes they are
my ictfax connects directly to the fs.. on port 5080
its a one box deployment.. i do have it deployed in a cluster but i havent switched over to it, because i'm too scared.. so at the moment my stuff is all still running on one box kamailio isnt really being used at all in current one box environment
CanDo
The point I'm trying to get at is if the call was setup though kamailio and then the reinvite skips kamailio, going directly to FS (port 11000), FS will always ignore it.
alpha-z, I started that way too. :D
alpha-z
:D
so i think that will be a problem when i switch to the cluster but at the moment
i'm still on basically fs only without kamailio
CanDo
Didn't know it would work without kamailio. :P
alpha-z
lol
i never knew kamailio even existed when i started using kazoo rofl
i was like whats this.. shrugs ignore
ok but how do i get fs to not ingore it if i'm using kamailio
CanDo
I really like having kamailio in front though. FS will always reply to new requests. Which is not really a good thing if you want to protect your self form scanners.
Since your not using kam, the problem I was thinking might exist is impossible.
alpha-z
well
i do have kamailio set up
i just dont use that port
CanDo
Are you doing a pcap on the kazoo box?
alpha-z
no i just have lots of trace logs in fs
CanDo
what port are you using?
alpha-z
on fs or kamailo
fs on that box is on 5080
CanDo
FS
alpha-z
kamailio is 5060 and 7000
CanDo
did you change it from the default 11000?
alpha-z
nope
:\
CanDo
where did you get FS install from?
alpha-z
back when i installed it the single server thing must have set that..
i just clicked install me from somewhere and it did it
dont remember was almost 2-3 years ago
maybe
CanDo
wow. that is old.
alpha-z
maybe? i'm using 3.16
lol
CanDo
oh you've just done incremental upgrades?
alpha-z
i may have updated it once or twice
ya
CanDo
well that is good then.
alpha-z
ok so kazoo got that reinvite to t38 from the ictfax
then it says it sent reply ... but ictfax (freeswitch) never gets it
strange thing is though the calls from ictfax in kazoo for send and recv in the sip packets always say send or receive to 127.0.0.1:someport then second line of packet is Via: then the 192.168.0.29 which is the ip of the ictfax
CanDo
that is really strange. FS to FS should be solid as a rock.
alpha-z
i've never seen that before
CanDo
are you sure you setup ictfax to connect to port 5080 on the kazoo box?
If you don't specify a port it will use the one kam is running on.
5060
alpha-z
yep. but only for the t38 stuff does the sip packets change to 127.0.0.1:port
CanDo
If you used the default install, kam should just hand it off to FS which very well might look like 127.0.0.1:port.
alpha-z
like the initial call the sip packets say received blabla bytes from 192.168.0.29:50xx.. etc.. but the second it has anything to do with t38..
CanDo
find out what the port in 127.0.0.1:port is.
alpha-z
then the packets go to 127.0.0.1:like random port like 8849
CanDo
can you pastebin the log?
if you don't want to clean up IP's just be sure to not make it a public pastie.
« prev 1 2 next »