logs archiveBotHelp.net / Freenode / #mopidy / 2015 / August / 19 / 1
adamcik
it doesn't fail locally
bah
jodal
feel free to merge yourself when that test passes
*zzz*
perplexa
100mb flacs + rpi1 + file backend = no good
:(
jodal
dz0ny: with that PR in, I'd like to make a mopidy-youtube 2.0.1 release
dz0ny
are you still planning to switch to responses?
snafu
ohh mopidy-youtube, then i can listen on Taylor Swift again since its removed in Spotify ;)
never heard of that plugin
jodal
dz0ny: it's probably quite a bit of work to replace all those youtube api calls
dz0ny
:)
jodal
and not as if being able to run tests as part of the debian package build is critical... none of my debian packages did it until yesterday
travis-ci didn't build PR's for m-y... fixed that now :-)
dz0ny: if you have the "0.1.0" and "1.0.1" tags locally, delete them
dz0ny: I've managed to push them from different computers at least twice now, but believe they have been purged properly now
dz0ny
I normally do git fetch -p :)
deals with all :)
jodal
and I use `git push --follow-tags`, which pushes all reachable tags :-/
dz0ny
jodal: fyi for yt mopidy needs gstreamer0.10-plugins-bad-multiverse in ubuntu repo
anncatrinausberl
hey guys... i tried to setup mopidy but got an error when i want to play music...
connect(2) call to /dev/shm/jack-1000/default/jack_0 failed (err=No such file or directory)
attempt to connect to server failed
jodal
dz0ny: while on debian -bad is enough?
dz0ny
jodal: it needs libfaac0
jodal
anncatrinausberl: are you on a raspberry pi with raspbian?
dz0ny
anncatrinausberl: do you use jack? normally you should have pulse or alsa
anncatrinausberl
raspberry pi yeah, but i am using arch linux
adamcik
anncatrinausberl: gstreamer seems to like to use jack for some reason, if you aren't actually using jack you probably want to change audio/ouput setting to alsasink or pulsesink
anncatrinausberl
i dont use jack
jodal
in your mopidy.conf, set "output = pulsesink" in the "[audio]" section. if that doesn't work, replace pulsesink with alsasink
anncatrinausberl
aye
jodal
(and restart mopidy inbetween your attempts)
anncatrinausberl
okay, the error is gone but there is another one
ERROR GStreamer error: state change failed and some element failed to post a proper error message with the reason for the failure.
jodal
what are you trying to play?
anncatrinausberl
.wav
jodal
humhum
try the other sink?
nothing arch specific in that message, but I'm wondering how arch is set up wrt what user mopidy is running as and access to the audio device
anncatrinausberl
same error
i am running mopidy as my own user
and i am not in the audio group m(
adamcik
not being in the audio group is probably to blame
anncatrinausberl
but adding me to this group didnt fixex the error
adamcik
did you start a new login shell?
anncatrinausberl
yes ;)
adamcik
strange
jodal
adamcik: `newgrp audio` also works... I only learned this after using linux for 15+ years
adamcik
mhm
anncatrinausberl
changed the sink back to alsasink
jodal
does `aplay youfile.wav` work?
anncatrinausberl
WARNING Element doesn't implement handling of this stream. Please file a bug.
new message ;)
and music is playing \o/
jodal
I'm guessing that maybe gstreamer would have choosen alsasink to begin with if you was in the audio group and had access to the audio device to begin with?
would be good to know. can you try removing the audio/output config?
anncatrinausberl
i guess the same, wait, i try...
you are right ;)
thank you! now i try to make mopidy running via systemd, for now i am running it manually with the command...
adamcik
that's good to hear, as we've already added some code to make gstreamer less likely to pick jack
anncatrinausberl
jeah, it was a little bit confusing
and i cannot get mopidy started via systemd for any reason :(
jodal
does `sudo journalctl -u mopidy` give you anything?
anncatrinausberl
well, its running, but i cannot connect or use the webinterface
oh there are errors
Aug 19 10:13:32 alarmpi mopidy[21435]: OSError: [Errno 13] Permission denied: '/var/lib/mopidy/.local'
i have no config like this :O
jodal
what version are you on? 1.1.0?
anncatrinausberl
yes
jodal
installed from arch's package manager?
anncatrinausberl
yes
jodal
can you paste the full stack trace somewhere?
anncatrinausberl
of course: http://pastebin.com/wBmVWjhA
is it the right one?
trygveaa
dz0ny: fyi, tags are not deleted with fetch -p
jodal
yes... looking at mopidy code now
trygveaa
they are also not redownloaded if they are changed on the server, only if you delete them and then fetch
adamcik
jodal: xdg.py I guess?
jodal
adamcik: __main__.py:170 ... why do we still do this?
adamcik
hmm, for the non service case it makes sense though
I think, any way
jodal
yes, it does, but not for a service
it's not like running mopidy as a service is new any longer
https://projects.archlinux.org/svntogit/community.git/tree/trunk/mopidy.install?h=packages/mopidy -- the choice of a specific uid/gid here looks fishy
https://projects.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/mopidy#n62 -- and then the reference to that uid/gid here, even though the user/group might exist with another uid/gid
and... most important in this case: /var/lib/mopidy/{local,media,playlists} is created and chowned to the mopidy user, but /var/lib/mopidy is not... so when another extension comes around and tries to make its own data dir, it will fail
jelle: ^^ have I understood correctly? anything you can fix?
anncatrinausberl: workaround for you: sudo chown -R mopidy:mopidy /var/lib/mopidy
anncatrinausberl: also, the output of the following command would be interesting: sudo -u mopidy -i python -c "from mopidy.internal import xdg; print xdg.get_dirs()"
adamcik: ah, it all comes from /var/lib/mopidy being the mopidy user's home dir
adamcik
as for the code on line 170, it should probably be using the new core settings
jodal
yes, it should... or a $FOO_DIR that uses the new core dir configs
I'm writing an issue
anncatrinausberl
jodal: the output is none
jodal
anncatrinausberl: ah, you're on arch. replace "python" with "python2"
anncatrinausberl
the same :o
jodal
anncatrinausberl: ok, no problem. I got enough from it on my ubuntu system to explain the behavior you had as well. did the workaround help?
anncatrinausberl
yes, mopidy runs, but i have no media files
jodal
you're using the mopidy-local extension? set the local/media_dir config in /etc/mopidy/mopidy.conf and restart
« prev 1 2 3 next »