logs archiveBotHelp.net / Freenode / #mopidy / 2015 / August / 8 / 1
tkem
(Action) streaming from Google Music and Qobuz via mopidy-dleyna and BubbleUPnP ;-)
oats
I'm trying to save a playlist in ncmpcpp, but it spits out an error: "MPD: Not Implemented"
can mopidy really not save playlists?
adamcik
nope, not via the MPD protocol. but https://github.com/mopidy/mopidy/pull/1187 is close to being merged now
oats
adamcik: excellent, thank you!
adamcik
if you use mopidy-mobile you should be able to edit things already now. but for instance mopidy-spotify doesn't support playlist editing
so you can probably "just" edit local m3u playlists for now
nineX_
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-Wjm9R3/pyspotify
when i try to run "pip install -U git+https://github.com/mopidy/mopidy-spotify@develop"
is there another method that I should be using to try to install the develop branch?
fails after
Collecting pyspotify>=2.0.2 (from Mopidy-Spotify==2.0.0)
Using cached pyspotify-2.0.2.tar.gz
should i be installing pyspotify-2.0.2 another way?
adamcik
try: pip install https://github.com/mopidy/pyspotify/archive/v2.x/develop.zip --upgrade
nineX_
Package libffi was not found in the pkg-config search path.
Perhaps you should add the directory containing `libffi.pc'
adamcik
I think I already installed that lib in ubuntu in my case
nineX_
mmm ok i will search around
trygveaa
have you installed python-cffi?
nvm, cffi you can get from pypi, but you need libffi from your distro
nineX_
how do you get that?
trygveaa
which distro do you run?
nineX_
raspbian wheezy
trygveaa
run: aptitude install libffi-dev
libffi is a c library, so it can't be installed with pip or be listed as a dependency for pip-packages
nineX_
hmmm its running now
thank you very much
trygveaa
np
nineX_
weird it didnt run with "apt-get install libffi-dev
"
build/temp.linux-armv6l-2.7/spotify._spotify.c:390:28: fatal error: libspotify/api.h: No such file or directory
i will just wait for 2.0 to hit master
:D
jodal
nineX_: you need to install libspotify from your distro too, ref the pyspotify docs
nineX_: if you have apt.mopidy.com in your /etc/apt/sources... you can just `sudo apt install libspotify-dev`
nineX_
thanks jodal
mopidyctl deps returns pyspotify<1.999,>=1.9: not found
weird
trygveaa
you just installed pyspotify 2, didn't you?
interesting, https://devaccount.spotify.com/my-account/keys/ says "we will be providing a new library for other platforms later this year"
wonder if that's true or not
« prev next »